Skip to content

Commit f58365e

Browse files
MATTER-2807-3 Fixed the openthread compatible issue with Yocto styhead
Fixed the compatible issue for the recipes to Yocto styhead. Signed-off-by: Haoran Wang <elven.wang@nxp.com> Change-Id: Id3d75e3088b3b18f08dec3183ec309db3d54b57b Reviewed-on: http://androidsource.nxp.com/project/26059 Reviewed-by: Junmeng Li <junmeng.li_1@nxp.com>
1 parent 14d24f6 commit f58365e

File tree

1 file changed

+5
-2
lines changed

1 file changed

+5
-2
lines changed

meta-nxp-openthread/recipes-openthread/openthread/openthread.bb

+5-2
Original file line numberDiff line numberDiff line change
@@ -8,10 +8,13 @@ python () {
88
distro_version = d.getVar('DISTRO_VERSION')
99
if "scarthgap" in distro_version:
1010
d.setVar('S', '${WORKDIR}/git')
11+
d.setVar('WORKPATH', '${WORKDIR}/git')
1112
elif "nanbield" in distro_version:
1213
d.setVar('S', '${WORKDIR}/git')
14+
d.setVar('WORKPATH', '${WORKDIR}/git')
1315
else:
1416
d.setVar('S', '${UNPACKDIR}/git')
17+
d.setVar('WORKPATH', '${UNPACKDIR}/')
1518
}
1619

1720
DEPENDS += " avahi boost readline "
@@ -23,8 +26,8 @@ inherit cmake
2326

2427
do_install() {
2528
install -d -m 755 ${D}${bindir}
26-
install ${S}/../build/src/posix/ot-daemon ${D}${bindir}
27-
install ${S}/../build/src/posix/ot-ctl ${D}${bindir}/ot-client-ctl
29+
install ${WORKPATH}/../build/src/posix/ot-daemon ${D}${bindir}
30+
install ${WORKPATH}/../build/src/posix/ot-ctl ${D}${bindir}/ot-client-ctl
2831
}
2932

3033
SRC_URI = "gitsm://github.com/openthread/openthread.git;branch=main;protocol=https"

0 commit comments

Comments
 (0)