-
Notifications
You must be signed in to change notification settings - Fork 1.3k
New issue
Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.
By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.
Already on GitHub? Sign in to your account
BGP Labelpool : Releasing the label in labelpool when VPN session gets removed #17580
Merged
ton31337
merged 2 commits into
FRRouting:master
from
varuntumbe:dev/label_pool_release_fix
Dec 23, 2024
Merged
Changes from all commits
Commits
Show all changes
2 commits
Select commit
Hold shift + click to select a range
File filter
Filter by extension
Conversations
Failed to load comments.
Loading
Jump to
Jump to file
Failed to load files.
Loading
Diff view
Diff view
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Empty file.
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,117 @@ | ||
interface r1-eth1 vrf vrf1 | ||
ip address 173.31.1.1/32 | ||
! | ||
interface r1-eth2 vrf vrf2 | ||
ip address 173.31.1.2/32 | ||
! | ||
interface r1-eth3 vrf vrf3 | ||
ip address 173.31.1.3/32 | ||
! | ||
interface r1-eth4 vrf vrf4 | ||
ip address 173.31.1.4/32 | ||
! | ||
interface r1-eth5 vrf vrf5 | ||
ip address 173.31.1.5/32 | ||
! | ||
|
||
interface r1-eth0 | ||
ip address 192.168.0.1/24 | ||
! | ||
|
||
interface r1-eth6 | ||
ip address 193.170.0.1/24 | ||
|
||
interface lo | ||
ip address 11.11.11.11/32 | ||
! | ||
router ospf | ||
ospf router-id 11.11.11.11 | ||
network 193.170.0.0/24 area 0.0.0.0 | ||
network 11.11.11.11/32 area 0.0.0.0 | ||
redistribute connected | ||
exit | ||
! | ||
mpls ldp | ||
router-id 11.11.11.11 | ||
! | ||
address-family ipv4 | ||
discovery transport-address 11.11.11.11 | ||
! | ||
interface r1-eth6 | ||
exit | ||
! | ||
exit-address-family | ||
! | ||
exit | ||
! | ||
bgp route-map delay-timer 1 | ||
router bgp 65500 | ||
bgp router-id 192.0.2.1 | ||
no bgp ebgp-requires-policy | ||
neighbor 192.168.0.2 remote-as 65501 | ||
address-family ipv4 unicast | ||
no neighbor 192.168.0.2 activate | ||
exit-address-family | ||
address-family ipv4 vpn | ||
neighbor 192.168.0.2 activate | ||
exit-address-family | ||
! | ||
router bgp 65500 vrf vrf1 | ||
bgp router-id 192.0.2.1 | ||
address-family ipv4 unicast | ||
redistribute connected | ||
label vpn export auto | ||
rd vpn export 445:1 | ||
rt vpn both 53:1 | ||
export vpn | ||
import vpn | ||
exit-address-family | ||
! | ||
router bgp 65500 vrf vrf2 | ||
bgp router-id 192.0.2.1 | ||
address-family ipv4 unicast | ||
redistribute connected | ||
label vpn export auto | ||
rd vpn export 445:2 | ||
rt vpn both 53:2 | ||
export vpn | ||
import vpn | ||
exit-address-family | ||
! | ||
router bgp 65500 vrf vrf3 | ||
bgp router-id 192.0.2.1 | ||
address-family ipv4 unicast | ||
redistribute connected | ||
label vpn export auto | ||
rd vpn export 445:3 | ||
rt vpn both 53:3 | ||
export vpn | ||
import vpn | ||
exit-address-family | ||
! | ||
router bgp 65500 vrf vrf4 | ||
bgp router-id 192.0.2.1 | ||
address-family ipv4 unicast | ||
redistribute connected | ||
label vpn export auto | ||
rd vpn export 445:4 | ||
rt vpn both 53:4 | ||
export vpn | ||
import vpn | ||
exit-address-family | ||
! | ||
router bgp 65500 vrf vrf5 | ||
bgp router-id 192.0.2.1 | ||
address-family ipv4 unicast | ||
redistribute connected | ||
label vpn export auto | ||
rd vpn export 445:5 | ||
rt vpn both 53:5 | ||
export vpn | ||
import vpn | ||
exit-address-family | ||
! | ||
|
||
interface r1-eth0 | ||
mpls bgp forwarding | ||
! |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,88 @@ | ||
interface r2-eth1 vrf vrf1 | ||
ip address 173.31.0.1/32 | ||
! | ||
interface r2-eth2 vrf vrf2 | ||
ip address 173.31.0.2/32 | ||
! | ||
interface r2-eth3 vrf vrf3 | ||
ip address 173.31.0.3/32 | ||
! | ||
interface r2-eth4 vrf vrf4 | ||
ip address 173.31.0.4/32 | ||
! | ||
interface r2-eth5 vrf vrf5 | ||
ip address 173.31.0.5/32 | ||
! | ||
interface r2-eth0 | ||
ip address 192.168.0.2/24 | ||
! | ||
router bgp 65501 | ||
bgp router-id 192.0.2.2 | ||
no bgp ebgp-requires-policy | ||
neighbor 192.168.0.1 remote-as 65500 | ||
address-family ipv4 unicast | ||
no neighbor 192.168.0.1 activate | ||
exit-address-family | ||
address-family ipv4 vpn | ||
neighbor 192.168.0.1 activate | ||
exit-address-family | ||
! | ||
router bgp 65501 vrf vrf1 | ||
bgp router-id 192.0.2.2 | ||
address-family ipv4 unicast | ||
redistribute connected | ||
label vpn export auto | ||
rd vpn export 445:1 | ||
rt vpn both 53:1 | ||
export vpn | ||
import vpn | ||
exit-address-family | ||
! | ||
router bgp 65501 vrf vrf2 | ||
bgp router-id 192.0.2.2 | ||
address-family ipv4 unicast | ||
redistribute connected | ||
label vpn export auto | ||
rd vpn export 445:2 | ||
rt vpn both 53:2 | ||
export vpn | ||
import vpn | ||
exit-address-family | ||
! | ||
router bgp 65501 vrf vrf3 | ||
bgp router-id 192.0.2.2 | ||
address-family ipv4 unicast | ||
redistribute connected | ||
label vpn export auto | ||
rd vpn export 445:3 | ||
rt vpn both 53:3 | ||
export vpn | ||
import vpn | ||
exit-address-family | ||
! | ||
router bgp 65501 vrf vrf4 | ||
bgp router-id 192.0.2.2 | ||
address-family ipv4 unicast | ||
redistribute connected | ||
label vpn export auto | ||
rd vpn export 445:4 | ||
rt vpn both 53:4 | ||
export vpn | ||
import vpn | ||
exit-address-family | ||
! | ||
router bgp 65501 vrf vrf5 | ||
bgp router-id 192.0.2.2 | ||
address-family ipv4 unicast | ||
redistribute connected | ||
label vpn export auto | ||
rd vpn export 445:5 | ||
rt vpn both 53:5 | ||
export vpn | ||
import vpn | ||
exit-address-family | ||
! | ||
|
||
interface r2-eth0 | ||
mpls bgp forwarding | ||
! |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,32 @@ | ||
interface r3-eth0 | ||
ip address 193.170.0.2/24 | ||
! | ||
interface lo | ||
ip address 33.33.33.33/32 | ||
! | ||
interface r3-eth1 | ||
ip address 180.170.0.2/32 | ||
! | ||
interface r3-eth2 | ||
ip address 180.170.0.3/32 | ||
! | ||
router ospf | ||
ospf router-id 33.33.33.33 | ||
network 193.170.0.0/24 area 0.0.0.0 | ||
network 33.33.33.33/32 area 0.0.0.0 | ||
redistribute connected | ||
exit | ||
! | ||
mpls ldp | ||
router-id 33.33.33.33 | ||
! | ||
address-family ipv4 | ||
discovery transport-address 33.33.33.33 | ||
! | ||
interface r3-eth0 | ||
exit | ||
! | ||
exit-address-family | ||
! | ||
exit | ||
! |
Oops, something went wrong.
Oops, something went wrong.
Add this suggestion to a batch that can be applied as a single commit.
This suggestion is invalid because no changes were made to the code.
Suggestions cannot be applied while the pull request is closed.
Suggestions cannot be applied while viewing a subset of changes.
Only one suggestion per line can be applied in a batch.
Add this suggestion to a batch that can be applied as a single commit.
Applying suggestions on deleted lines is not supported.
You must change the existing code in this line in order to create a valid suggestion.
Outdated suggestions cannot be applied.
This suggestion has been applied or marked resolved.
Suggestions cannot be applied from pending reviews.
Suggestions cannot be applied on multi-line comments.
Suggestions cannot be applied while the pull request is queued to merge.
Suggestion cannot be applied right now. Please check back later.
There was a problem hiding this comment.
Choose a reason for hiding this comment
The reason will be displayed to describe this comment to others. Learn more.
please add a comment block explaining the dual uses of this new function
There was a problem hiding this comment.
Choose a reason for hiding this comment
The reason will be displayed to describe this comment to others. Learn more.
Added the comment